Thursday, May 8, 2008

How to reinstall the Windows TCP/IP stack

It's been a long time since I blogged anything technical. In my current job I am quite far from technology, which is a drag, but kind of part of the dues of moving along in my career. However, I still get some opportunities to do geeky stuff.

For example, my neighbor just called me with a problem with his Windows XP machine. He had gotten hit with a virus. Norton took care of it, but his browser no longer worked.

I fired up a command prompt and pinged google. I got this:

Pinging www.l.google.com [ºÿ] with 32 bytes of data:
Reply from 64.233.167.99: bytes=32 time=63ms TTL=245
Reply from 64.233.167.99: bytes=32 time=63ms TTL=245
Reply from 64.233.167.99: bytes=32 time=63ms TTL=245
Reply from 64.233.167.99: bytes=32 time=63ms TTL=245
...

Which was kind of what I expected, except for the weird ºÿ characters in the first line. I started to suspect that my neighbor's TCP/IP stack was messed up. In the past, I seemed to remember fixing this by deinstalling TCP/IP and reinstalling it.

But when I went to deinstall TCP/IP, I saw that the "uninstall" button was grayed out. Hmm.

A little research on the Internet (always have a second computer!) revealed a single command that could be used to "reinstall" TCP/IP. It doesn't really reinstall it, it just resets the configuration of it:

netsh winsock reset

After this, Windows asked me to restart. When I went to the signoff login, the "Shutdown" button had a message that stated that shutting down would install a necessary update. I chose to shutdown.

When the PC rebooted, everything worked! There are more details on this technique here:

http://support.microsoft.com/kb/811259

1 comment:

I moderate comments blog posts over 14 days old. This keeps a lot of spam away. I generally am all right about moderating. Thanks for understanding.